1С:Предприятие 8
Система программ
06.12.2016
a:2:{s:4:"TYPE";s:4:"HTML";s:4:"TEXT";s:125783:"

Версия 1.1.22

Версия 1.1.22 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • реализована система оповещений о событиях ЭДО (новые электронные документы, новые приглашения, окончание срока действия сертификата и т.д.). Появилась возможность настройки уведомлений на электронную почту в профиле настроек ЭДО, а так же вывод оповещения о событиях непосредственно в программе 1С с помощью всплывающих сообщений;
  • поддержан формат первичного документа, включающего в себя счет-фактуру (формат УПД) в соответствии с приказом Федеральной налоговой службы от 24.03.2016 № ММВ-7-15/155@ "Об утверждении формата счета-фактуры и формата представления документа об отгрузке товаров (выполнении работ), передаче имущественных прав (документа об оказании услуг), включающего в себя счет-фактуру, в электронной форме";
  • поддержан формат документа об изменении стоимости, включающего в себя корректировочный счет-фактуру" (формат УКД) в соответствии с приказом Федеральной налоговой службы от 13.04.2016 N ММВ-7-15/189@ "Об утверждении формата корректировочного счета-фактуры и формат представления документа об изменении стоимости отгруженных товаров (выполненных работ, оказанных услуг), переданных имущественных прав, включающего в себя корректировочный счет-фактуру, в электронной форме";
  • поддержаны форматы первичных документов счетов-фактур (в части передачи отдельного первичного документа, счет-фактуры) в соответствии с приказом Федеральной налоговой службы от 24.03.2016 № ММВ-7-15/155@ "Об утверждении формата счета-фактуры и формата представления документа об отгрузке товаров (выполнении работ), передаче имущественных прав (документа об оказании услуг), включающего в себя счет-фактуру, в электронной форме";
  • поддержаны форматы первичных документов об изменении стоимости, включающего в себя корректировочный счет-фактуру" (в части передачи отдельного первичного документа, корректировочного счет-фактуры) в соответствии с приказом Федеральной налоговой службы от 13.04.2016 N ММВ-7-15/189@ "Об утверждении формата корректировочного счета-фактуры и формат представления документа об изменении стоимости отгруженных товаров (выполненных работ, оказанных услуг), переданных имущественных прав, включающего в себя корректировочный счет-фактуру, в электронной форме";
  • добавлены новые электронные документы Передача товаров, Передача результатов работ, новая форма визуального представления документов;
  • добавлен механизм одностороннего обмена, не требующий извещения о получении от получателя
  • исправлены выявленные ошибки.

Переход на версию 1.1.22 с версии 1.1.20, 1.1.21

Изменения в подсистеме "Обмен с контрагентами".

Изменения в формах списков документов прикладного решения

В формах списков документов необходимо добавить подключаемую процедуру Подключаемый_ОбработчикОжиданияЭДО, в которой нужно разместить вызов метода
ЭлектронныеДокументыКлиент.ОбработчикОжиданияЭДО:


&НаКлиенте
Процедура Подключаемый_ОбработчикОжиданияЭДО()
     
       ЭлектронныеДокументыКлиент.ОбработчикОжиданияЭДО(ЭтаФорма);
     
КонецПроцедуры

Если подменю ЭДО не является группой команд ЭД , то в процедуру ЭлектронныеДокументыКлиент.ОбработчикОжиданияЭДО необходимо передать элемент формы или массив элементов , который является подменю:


&НаКлиенте
Процедура Подключаемый_ОбработчикОжиданияЭДО()
     
            
       ПараметрыОбработчика = ЭлектронныеДокументыКлиент.ПараметрыОбработчикаОжиданияЭДО();
       ПараметрыОбработчика.ПодменюЭДО = ПодменюЭДО(Элементы);
       ЭлектронныеДокументыКлиент.ОбработчикОжиданияЭДО(ЭтаФорма, ПараметрыОбработчика);
     
КонецПроцедуры


При обновлении подсистемы необходимо в обработчиках событий формы списка документов:

  • ПриСозданииНаСервере
  • ПриОткрытии
  • ОбработкаОповещения

разместить методы подсистемы «ЭлектронныеДокументы».
Например:


&НаСервере
Процедура ПриСозданииНаСервере

       // Подсистема "Электронные документы".
       ПараметрыПриСозданииНаСервере = ЭлектронныеДокументы.ПараметрыПриСозданииНаСервере_ФормаСписка();
       ПараметрыПриСозданииНаСервере.Форма = ЭтаФорма;
       ЭлектронныеДокументы.ПриСозданииНаСервере_ФормаСписка(Отказ, СтандартнаяОбработка, ПараметрыПриСозданииНаСервере);
       // Конец подсистема "Электронные документы".
 КонецПроцедуры
 
&НаКлиенте
Процедура ПриОткрытии(Отказ)
…    
       // Подсистема "Электронные документы".
       ЭлектронныеДокументыКлиент.ПриОткрытии(ЭтаФорма);
       // Конец подсистема "Электронные документы".
 КонецПроцедуры
 
&НаКлиенте
 
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)

       // Подсистема "ЭлектронныеДокументы".
       ПараметрыОповещения = ЭлектронныеДокументыКлиент.ПараметрыОповешенияЭДО_ФормаСписка();
       ПараметрыОповещения.Форма = ЭтаФорма;
       ПараметрыОповещения.ИмяДинамическогоСписка = "СписокРеализацииТоваровУслуг";
     
       ЭлектронныеДокументыКлиент.ОбработкаОповещения_ФормаСписка(ИмяСобытия, Параметр, Источник, ПараметрыОповещения);
       //  Конец подсистема "ЭлектронныеДокументы".
КонецПроцедуры


Изменения в формах документов прикладного решения:

В формах документов необходимо добавить подключаемую процедуру Подключаемый_ОбработчикОжиданияЭДО, в которой нужно разместить вызов метода
ЭлектронныеДокументыКлиент.ОбработчикОжиданияЭДО:


&НаКлиенте
Процедура Подключаемый_ОбработчикОжиданияЭДО()
     
       ЭлектронныеДокументыКлиент.ОбработчикОжиданияЭДО(ЭтаФорма);
     
КонецПроцедуры

В формах документов необходимо удалить реквизит формы «СостояниеЭДО», вместо него добавить элемент формы «декорация».

При обновлении подсистемы необходимо в обработчиках событий формы документа:

  • ПриСозданииНаСервере
  • ПриОткрытии
  • ПослеЗаписиНаСервере
  • ОбработкаОповещения

разместить методы подсистемы «ЭлектронныеДокументы».
Например:


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
…    
       // Подсистема "ЭлектронныеДокументы".
       ПараметрыПриСозданииНаСервере = ЭлектронныеДокументы.ПараметрыПриСозданииНаСервере_ФормаДокумента();
       ПараметрыПриСозданииНаСервере.Форма = ЭтаФорма;
       ПараметрыПриСозданииНаСервере.ДокументСсылка = Объект.Ссылка;
       ПараметрыПриСозданииНаСервере.ДекорацияСостояниеЭДО = Элементы.ДекорацияСостояниеЭДО;
     
       ЭлектронныеДокументы.ПриСозданииНаСервере_ФормаДокумента(Отказ, СтандартнаяОбработка, ПараметрыПриСозданииНаСервере);
       // Конец подсистема "ЭлектронныеДокументы".
 КонецПроцедуры
 
&НаКлиенте
Процедура ПриОткрытии(Отказ)
…    
       // Подсистема "ЭлектронныеДокументы".
       ЭлектронныеДокументыКлиент.ПриОткрытии(ЭтаФорма);
       // Конец подсистема "ЭлектронныеДокументы".
 КонецПроцедуры
 
&НаСервере
Процедура ПослеЗаписиНаСервере(ТекущийОбъект, ПараметрыЗаписи)
…    
       // Подсистема "ЭлектронныеДокументы".
       ПараметрыПослеЗаписиНаСервере = ЭлектронныеДокументы.ПараметрыПослеЗаписиНаСервере();
       ПараметрыПослеЗаписиНаСервере.ДекорацияСостояниеЭДО = Элементы.ДекорацияСостояниеЭДО;
       ПараметрыПослеЗаписиНаСервере.ДокументСсылка = Объект.Ссылка;
     
       ЭлектронныеДокументы.ПослеЗаписиНаСервере(ТекущийОбъект, ПараметрыЗаписи, ПараметрыПослеЗаписиНаСервере);//ЭтаФорма, Объект.Ссылка, Элементы.ДекорацияСостояниеЭДО);
       // Конец подсистема "ЭлектронныеДокументы".  
КонецПроцедуры
 
&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
…    
       // Подсистема "ЭлектронныеДокументы".
       ПараметрыОповещенияЭДО = ЭлектронныеДокументыКлиент.ПараметрыОповешенияЭДО_ФормаДокумента();
       ПараметрыОповещенияЭДО.Форма = ЭтаФорма;
       ПараметрыОповещенияЭДО.ДокументСсылка = Объект.Ссылка;
       ПараметрыОповещенияЭДО.ДекорацияСостояниеЭДО = Элементы.ДекорацияСостояниеЭДО;
     
       ЭлектронныеДокументыКлиент.ОбработкаОповещения_ФормаДокумента(ИмяСобытия, Параметр, Источник, ПараметрыОповещенияЭДО);
       // Конец подсистема "ЭлектронныеДокументы".  
КонецПроцедуры

Изменения в модуле ЭлектронныеДокументы:

Добавлена процедура ПриСозданииНаСервере_ФормаСписка, вызывается из обработчика события «ПриСозданииНаСервере» формы списка документов. В качестве третьего параметра метода передается структура, которая инициализируется  методом ПараметрыПриСозданииНаСервере_ФормаСписка.
 
Добавлена процедура ПриСозданииНаСервере_ФормаДокумента, вызывается из обработчика события «ПриСозданииНаСервере» формы документа. В качестве третьего параметра метода передается структура, которая инициализируется  методом ПараметрыПриСозданииНаСервере_ФормаДокумента.
 
Добавлена процедура ПослеЗаписиНаСервере, вызывается из обработчика события «ПослеЗаписиНаСервере» формы документа. В качестве третьего параметра метода передается структура, которая инициализируется методом ПараметрыПослеЗаписиНаСервере.

Изменения в модуле ЭлектронныеДокументыКлиент:

Добавлена процедура ПриОткрытии, вызывается из обработчика события «ПриОткрытии» формы списка документов и формы документа.

Добавлена процедура ОбработкаОповещения_ФормаСписка,  вызывается из обработчика события «ОбработкаОповещения» формы списка документов. В качестве четвертого параметра метода передается структура, которая инициализируется методом ПараметрыОповешенияЭДО_ФормаСписка.

Добавлена процедура ОбработкаОповещения_ФормаДокумента,  вызывается из обработчика события «ОбработкаОповещения» формы документа. В качестве четвертого параметра метода передается структура, которая инициализируется методом ПараметрыОповешенияЭДО_ФормаДокумента.
 
Добавлена процедура ОбработчикОжиданияЭДО,  вызывается из подключаемой процедуры «Подключаемый_ОбработчикОжиданияЭДО» формы списка документов и формы документа. В качестве второго параметра метода может передаваться структура, которая инициализируется методом ПараметрыОбработчикаОжиданияЭДО.

Изменения в модуле ЭлектронныеДокументыПереопределяемый:

Добавлен метод ЗаполнитьДанныеДляУПДИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УПД (информация продавца) функция СЧФДОП.

Добавлен метод ЗаполнитьДанныеДляУПДИнформацииПокупателяФНС. Метод подготавливает данные для электронного документа типа УПД (информация покупателя) функция СЧФДОП.

Добавлен метод НайтиСоздатьУниверсальныйПередаточныйДокумент. Метод сохраняет данные из электронного документа УПД (информация продавца) функция СЧФДОП в объекты ИБ.

Добавлен метод ЗаполнитьДанныеДляДОПИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УПД (информация продавца) функция ДОП.

Добавлен метод НайтиСоздатьУПДДокументОПередаче. Метод сохраняет данные из электронного документа УПД (информация продавца) функция ДОП в объект ИБ.

Добавлен метод ЗаполнитьДанныеДляСЧФИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УПД (информация продавца) функция СЧФ.

Добавлен метод НайтиСоздатьУПДСчетФактуру. Метод сохраняет данные из электронного документа УПД (информация продавца) функция СЧФ в объект ИБ.

Добавлен метод ЗаполнитьДанныеДляУКДИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УКД (информация продавца) функция КСЧФДИС.

Добавлен метод ЗаполнитьДанныеДляУКДИнформацииПокупателяФНС. Метод подготавливает данные для электронного документа типа УКД (информация покупателя) функция КСЧФДИС.

Добавлен метод НайтиСоздатьУниверсальныйКорректировочныйДокумент. Метод сохраняет данные из электронного документа УКД (информация продавца) функция КСЧФДИС в объекты ИБ.

Добавлен метод ЗаполнитьДанныеДляДИСИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УКД (информация продавца) функция ДИС.

Добавлен метод НайтиСоздатьУКДДокументОбИзмененииСтоимости. Метод сохраняет данные из электронного документа УКД (информация продавца) функция ДИС в объект ИБ.

Добавлен метод ЗаполнитьДанныеДляКСЧФИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УКД (информация продавца) функция КСЧФ.

Добавлен метод НайтиСоздатьУКДСчетФактуру. Метод сохраняет данные из электронного документа УКД (информация продавца) функция КСЧФ в объект ИБ.

Добавлен метод СоответствиеИсходящихВидовЭДДокументамИБ. Метод формирует соответствие исходящих электронных документов и документов ИБ.

Добавлен метод НайтиСоздатьДокументПередачаРезультатовРабот. Метод используется заполнения документа Товарная накладная, полученного в формате «Передача товаров».

Добавлен метод НайтиСоздатьДокументПередачаТоваров. Метод используется заполнения документа Акт об оказании услуг, полученного в формате «Передача результатов работ».

Изменения в обработке ЭлектронныеДокументы:

В макете «Торг-12Продавец»:

  • добавлена  табличная часть «Основание»,
  • удалены поля «ДокументОснованиеНаименование», «ДокументОснованиеНомер», «ДокументОснованиеДата», «ДокументОснованиеДопСведения»,
  • добавлено поле «ИдГосКонтракта»,
  • добавлена табличная часть «ТранспортнаяНакладная»,
  • удалены поля «ТранспортнаяНакладнаяДата», «ТранспортнаяНакладнаяНомер»,
  • добавлено поле «СведенияОЛицеПередавшемТовары»,
  • в свойствах участников сделки поле «Факс» заменено на поле «ЭлектроннаяПочта»,
  • в свойствах участников сделки поле «КодСтр» заменено на поле «КодСтраны»,
  • в свойствах участников сделки поле «АдрТекст» заменено на поле «АдресТекст».

В макете «Акт501_Исполнитель»:

  • добавлена  табличная часть «Основание»,
  • удалены поля «ДокументОснованиеНаименование», «ДокументОснованиеНомер», «ДокументОснованиеДата», «ДокументОснованиеДопСведения»,
  • добавлено поле «ВалютаНаименование»,
  • добавлено поле «Претензии»,
  • добавлено поле «ДатаИсполнения»,
  • в свойствах участников сделки поле «Факс» заменено на поле «ЭлектроннаяПочта»,
  • в свойствах участников сделки поле «КодСтр» заменено на поле «КодСтраны»,
  • в свойствах участников сделки поле «АдрТекст» заменено на поле «АдресТекст».


Версия 1.1.21.7

Версия 1.1.21.7 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • в соответствии с Приказом от 30.11.2015 № ММВ-7-10/551@ "Об утверждении формата представления документа о передаче товаров при торговых операциях в электронной форме" и Приказом от 30.11.2015 № ММВ-7-10/552@ "Об утверждении формата представления документа о передаче результатов работ (документа об оказании услуг) в электронной форме" поддержаны новые форматы электронных документов;
  • реализовано отображение 2-х титулов электронных документов (ТОРГ12, Акт, Корректировочные документы) в единой форме просмотра электронного документа. Вся информация из титулов будет собрана на единую форму. Отдельно форму второго титула можно будет посмотреть из формы "Электронный документы";
  • реализована возможность заключать типовое "Соглашение об ЭДО" в электронном виде из "Настройки ЭДО" в программе 1С; По команде "Сформировать соглашение по шаблону" автоматически будет создан произвольный электронный документ, вложением которого будет файл соглашения. После подписания документ можно будет сразу отправить контрагенту.
  • интегрирован обмен произвольными электронными документами с присоединенными файлами. Теперь любой присоединенный файл можно быстро подписать и отправить контрагенту с помощью произвольного электронного документа;
  • исправлены выявленные ошибки.

Переход на версию 1.1.21.7 с версии 1.1.19.4, 1.1.20.5

Изменения в подсистеме "Обмен с контрагентами".

В модуле ЭлектронныеДокументыПереопределяемый внести изменение:

// Подготавливает данные для электронного документа типа ТоварнаяНакладная.
//
// Параметры:
// СсылкаНаЭД - Ссылка на ЭД, по которому необходимо сформировать электронный документ,
// СтруктураЭД - Структура, структура данных для формирования электронного документа.
// ДеревоДанных - дерево значений, дерево данных заполнения электронного документа.
//
Процедура ЗаполнитьДанныеПередачаТоваровПродавец(СсылкаНаОбъект, СтруктураЭД, ДеревоДанных) Экспорт
ЗаполнитьДанныеПоТорг12ПродавецФНС(СсылкаНаОбъект, СтруктураЭД, ДеревоДанных)
КонецПроцедуры
 
// Подготавливает данные для электронного документа типа Акт об оказанных услугах.
//
// Параметры:
//  СсылкаНаЭД   - Ссылка на ЭД, по которому необходимо сформировать электронный документ,
//  СтруктураЭД  - Структура, структура данных для формирования электронного документа.
//  ДеревоДанных - Дерево значений, дерево данных заполнения электронного документа.
//
Процедура ЗаполнитьДанныеПередачаРаботИсполнитель(СсылкаНаОбъект, СтруктураЭД, ДеревоДанных) Экспорт
  ЗаполнитьДанныеПоАкт501ИсполнительФНС(СсылкаНаОбъект, СтруктураЭД, ДеревоДанных)
 КонецПроцедуры

Изменения реквизита произвольного электронного документа ДокументОснование:

Необходимо указать какие документы будут являться основанием. Как правило это все документы, на основании которых формируются формализванные электронные документы.

Изменения типа параметра общей команды СтруктураПодчиненности:

Отметить Произвольный документ.

Изменения состава критерия отбора СвязанныеДокументы:

Добавить Документ.ПроизвольныйЭД.Реквизит.ДокументОснование.


Версия 1.1.21.7


Версия 1.1.20.5

Версия 1.1.20.5 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • реализована возможность быстрого подключения к сервису 1С-ЭДО по гиперссылке в блоке ЭДО на формах документов информационной базы;
  • добавлена колонка на форме списка (форме выбора) справочника "Контрагенты" с отображением признака подключенности контрагента к сервису 1С-ЭДО;
  • исправлены выявленные ошибки.

Переход на версию 1.1.20.5 с версии 1.1.18.6, 1.1.19.4

В макетах АктНаПередачуПрав, ЗаказТовара, ОтветНаЗаказ, ОтчетКомиссионераОПродажах, ОтчетКомиссионераОСписании, СчетНаОплату, КаталогТоваров, ПрайсЛист в группе параметров "Банк" у поле "БИК" изменен признак обязательного заполнения. Необходимо предусмотреть заполнение данного поля;

Изменения в модуле ЭлектронныеДокументыПереопределяемый:

В метод ПолучитьСоответствиеНаименованийОбъектовМДиРеквизитов добавлены для переопределения два ключа:

    • РеализацияТоваровУслугВМетаданных
    • ПоступлениеТоваровУслугВМетаданных

Изменения в модуле ЭлектронныеДокументы:

Добавлен метод ПроверитьКонтрагентаВ1СЭДОПриСозданииНаСервере, который необходимо вызвать при создании формы контрагента. Данный метод запускает проверку на подключение контрагента к сервису 1С-ЭДО.

Пример ЭлектронныеДокументы.ПроверитьКонтрагентаВ1СЭДОПриСозданииНаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
// ЭлектронноеВзаимодействие.ОбменСКонтрагентами
ЭлектронныеДокументы.ПроверитьКонтрагентаВ1СЭДОПриСозданииНаСервере(Объект.Ссылка);
// Конец ЭлектронноеВзаимодействие.ОбменСКонтрагентами
КонецПроцедуры

Добавлено НЕ разделенное регламентное задание ПроверкаКонтрагентовБЭД, которое делает выборку контрагентов и выполняет по ним проверку подключения к 1С-ЭДО.

Добавлен разделенный регистр сведений СостоянияКонтрагентовБЭД, в котором собирается статистика по подключенным контрагентам к сервису 1С-ЭДО.

Добавить вывод признака подключения к сервису 1С-ЭДО в колонку "ЭДО" на форме списка и форме выбора контрагентов. Добавить подсказку к колонке "Подключен к сервису 1С-ЭДО".

Пример
"ВЫБРАТЬ
ВЫБОР
КОГДА СостоянияКонтрагентовБЭД.Состояние = ЗНАЧЕНИЕ(Перечисление.СостоянияКонтрагентаБЭД.Подключен)
ТОГДА 0
ИНАЧЕ 1
КОНЕЦ
КОНЕЦ КАК ЭДО,
СправочникКонтрагенты.Наименование,
СправочникКонтрагенты.ИНН,
СправочникКонтрагенты.КПП,
....
СправочникКонтрагенты.НаименованиеПолное
ИЗ
Справочник.Контрагенты КАК СправочникКонтрагенты
ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.СостоянияКонтрагентовБЭД КАК СостоянияКонтрагентовБЭД
ПО (СостоянияКонтрагентовБЭД.Контрагент = СправочникКонтрагенты.Ссылка)"

На формах документов информационной базы убрать привязку к функциональной опции "ИспользоватьОбменЭД" у реквизита формы "ТекстСостоянияЭД". Удалить заголовок у реквизита "Состояние ЭД".


Версия 1.1.19.4

Версия 1.1.19.4 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • упрощен интерфейс пользователя по работе с формой просмотра электронного документа и командами ЭДО;
  • расширен функционал по работе с приглашениями в 1С-ЭДО;
  • исправлены выявленные ошибки.

Переход на версию 1.1.19.4 с версии 1.1.17.6, 1.1.18.6


Версия 1.1.18.6

Версия 1.1.18.6 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • в соответствии с Приказом ФНС РФ от 02.02.2015 № ММВ-7-15/40@ "Об утверждении форматов счета-фактуры, журнала учета полученных и выставленных счетов-фактур, книги покупок и книги продаж, дополнительных листов книги покупок и книги продаж в электронной форме" обновлены форматы документов "Счет-фактура" и "Корректировочный счет-фактура";
  • в соответствии с Приказом ФНС РФ от 04.03.2015 № ММВ-7-6/93@ "О внесении изменений в приказ ФНС России от 21.03.2012 № ММВ-7-6/172@" обновлены форматы документов "ТОРГ12" и "Акта приемки-сдачи работ (услуг)";
  • исправлены выявленные ошибки

Переход на версию 1.1.18.6 с версии 1.1.16.10, 1.1.17.6


Версия 1.1.17.6

Версия 1.1.17.6 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • реализовано подключение и обмен электронными документами через сервис 1С-ЭДО. Теперь появилась возможность обмениваться электронными документами через оператора ЭДО «Калуга Астрал»;
  • в форме просмотра эл.документа добавлено визуальное представление дополнительных данных передаваемых вместе с электронными документами форма CML 2.08 (заказ покупателя, заказ поставщику, счет на оплату и т.д.);
  • исправлены выявленные ошибки.

Переход на версию 1.1.17.6 с версии 1.1.15.13, 1.1.16.10

В макетах АктНаПередачуПрав, ЗаказТовара, ОтветНаЗаказ, ОтчетКомиссионераОПродажах, ОтчетКомиссионераОСписании,
СчетНаОплату в группу "ДопДанные" добавлено поле "НеПодписанные".
В макетах КаталогТоваров, ПрайсЛист добавлена группа "ДопДанные.НеПодписанные".

При заполнении выше указанных параметров в переопределяемой части, значения будут передаваться вместе с электронным документом с помощью мехнизма передачи доп. данных. Взависимости от группы "Подписанные" или "НеПодписанные" данные будет передавать внутри эл.документа или же отдельным файлом.


Версия 1.1.16.10

Версия 1.1.16.10 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • поддержан механизм аннулирования эл.документов (кроме ЭСФ);
  • добавлена возможность передавать доп.данные для эл.документов в формате CML;
  • реализована возможность оставлять "комментарии" по эл.документу (для внутреннего использования), а также заполнять "сопроводительную записку" (для отправки получателю);
  • поддержан обмен исправительным "Актом на передачу прав" в эл. виде;
  • реализована единая форма "карточки" эл.документа, в т.ч и для "Произвольного эл.документа", с возможностью предпросмотра перед печатью;
  • для удобства маршрутизации эл.документов добавлена команда "Направить на рассмотрение" (для операций утверждения, подписания и пр.);
  • реализован быстрый переход в список эл.документов с позиционированием на текущем элементе из наиболее часто используемых форм: форма просмотра эл.документа, "Текущие дела ЭДО", "Архив ЭДО";
  • в ЭСФ переименована команда "Отклонить электронный документ" в "Запросить уточнение по электронному документу";
  • исправлены выявленные ошибки.

Переход на версию 1.1.16.10 с версии 1.1.14.4, 1.1.15.11, 1.1.15.13

В макете АктНаПередачуПрав добавлены поля:

  • ВидОперации;
  • НомерИсправления;
  • ДатаИсправления;

Заполняются при формировании Исправительного и Корректировочного акта на передачу прав.

  • ДокументыСделки, заполняется таблица данными по документам сделки(договор, дата и номер платежного поручения);
  • ДопДанные.Подписанные, заполняются при передаче доп. данных шапки документа информациионной базы;
  • Товары.СерийныеНомера
  • Товары.ДокументОснования, заполняется при передаче документов оснований в табличной части документа информациионной базы.
  • Товары.ДопДанныеПодписанные, заполняется при передаче доп. данных табличной части документа информациионной базы.

Изменены поля:
Поле ДокументыОснования вместо таблицы значений имет тип Ссылка или МассивСсылок.

В макете ЗаказТовара добавлены поля:

  • ДоговорНомер;
  • ДоговорДата;
  • РасчетныйСчет;
  • ДокументыОснования, заполняется при передаче документов оснований шапки документа информациионной базы.
  • ДопДанные.Подписанные, заполняются при передаче доп. данных шапки документа информациионной базы;
  • Товары.ДокументОснования, заполняется при передаче документов оснований в табличной части документа информациионной базы;
  • Товары.ДопДанныеПодписанные, заполняется при передаче доп. данных табличной части документа информациионной базы.

В макете КаталогТоваров добавлены поля:

  • Товары.ДопДанныеПодписанные, заполняется при передаче доп. данных табличной части документа информациионной базы.

В макете ОтветНаЗаказ добавлены поля:

  • ДоговорНомер;
  • ДоговорДата;
  • РасчетныйСчет;
  • ДокументыОснования, заполняется при передаче документов оснований шапки документа информациионной базы.
  • ДопДанные.Подписанные, заполняются при передаче доп. данных шапки документа информациионной базы;
  • Товары.ДокументОснования, заполняется при передаче документов оснований в табличной части документа информациионной базы;
  • Товары.ДопДанныеПодписанные, заполняется при передаче доп. данных табличной части документа информациионной базы.

В макете ОтчетКомиссионераОПродажах добавлены поля:

  • ДопДанные.Подписанные, заполняются при передаче доп. данных шапки документа информациионной базы;
  • Товары.ДопДанныеПодписанные, заполняется при передаче доп. данных табличной части документа информациионной базы.

В макете ОтчетКомиссионераОСписании добавлены поля:

  • ДопДанные.Подписанные, заполняются при передаче доп. данных шапки документа информациионной базы;
  • Товары.ДопДанныеПодписанные, заполняется при передаче доп. данных табличной части документа информациионной базы.

В макете ПрайсЛист добавлены поля:

  • Товары.ДопДанныеПодписанные, заполняется при передаче доп. данных табличной части документа информациионной базы.

В макете СчетНаОплату добавлены поля:

  • ДокументыОснования, заполняется при передаче документов оснований шапки документа информациионной базы.
  • ДопДанные.Подписанные, заполняются при передаче доп. данных шапки документа информациионной базы;
  • Товары.ДокументОснования, заполняется при передаче документов оснований в табличной части документа информациионной базы;
  • Товары.ДопДанныеПодписанные, заполняется при передаче доп. данных табличной части документа информациионной базы.

Во всех макетах ЭД(кроме вторых титулов): добавлено поле СопроводительнаяЗаписка.

При подготовке данных в модуле ЭлектронныеДокументыПереопределяемый в поле СопроводительнаяЗаписка можно записывать программно сформированное сообщение для получателя электронного документа.


Версия 1.1.15.13

Версия 1.1.15.3 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

Исправлены выявленные ошибки.


Версия 1.1.15.11

Версия 1.1.15.11 содержит исправления известных ошибок продукта "1С:Библиотека электронных документов 8.2".

Новые возможности и изменения

  • поддержано изменение размерности кодов единиц измерений - "Изменение N 8/2013 Общероссийский классификатор единиц измерения (ОКЕИ) ОК 015-94 (МК 002-97)"(утв. Приказом Росстандарта от 26.09.2013 N 1101-ст);
  • реализована возможность хранения пароля к закрытой части ключа электронной подписи на время работы клиентского сеанса;
  • добавлено автоматическое определение необходимости формирования ответной подписи на электронном документе (если входящий электронный документ был подписан, то в ответ требуется также подписать электронный документ);
  • добавлен тест настроек сертификата электронной подписи для прямого обмена с контрагентами;
  • добавлена возможность отслеживать "приглашения к обмену" в обработке "Текущий дела ЭДО";
  • реализован вывод причины отклонения электронного документа в список элементов группировок "Обработать" и "Уточнить" формы "Текущие дела ЭДО";
  • добавлена возможность запросить уточнение по электронному документу при прямом обмене с контрагентом;
  • добавлена возможность выбора формата версии для видов электронных документов, обмен которыми возможен по разным версиям XML-формата;
  • реализовано создание "Настроек ЭДО" по входящим "приглашениям к обмену" от контрагента;
  • реализовано получение актуальных статусов и отправка приглашений при обмене через оператора ЭДО по команде "Отправить и получить электронные документы", а также через регламентные задания;
  • для более гибкого использования настроек ЭДО в рамках обмена с одним контрагентом добавлена возможность указать "Договор контрагента";
  • добавлена возможность подключать контрагентов прямо из формы элемента справочника "Контрагенты", а также из документа-основания информационной базы;
  • добавлена возможность работы с функционалом электронных документов в режиме "только просмотр" по закрытой настройке ЭДО;
  • добавлена возможность принудительного прекращения ЭДО из обработки "Текущие дела ЭДО";
  • оптимизирован порядок записи в системный журнал регистрации по событиям ЭДО для удобной фильтрации;
  • переработан поиск документов-оснований для электронных счетов-фактур при комиссионной торговле;
  • исправлены выявленные ошибки.

Переход на версию 1.1.15.11 с версии 1.1.13.7, 1.1.14.3, 1.1.14.4.

Добавлен новый справочник Профили настроек ЭДО.

Помечен к удалению регистр сведений УдалитьУчастникиОбменовЭДЧерезОператоровЭДО.

В общем модуле ЭлектронныеДокументыПереопределяемый:

В методе ЗаполнитьПараметрыЭДПоИсточнику необходимо добавить заполнение договора контрагента.

Добавлены новые методы:

  • заполнитьСоответствиеСтавокНДС, в котором необходимо опеределить соотвествие ставок НДС прикладного решения;
  • дополнительнаяАналитикаСправочникХарактеристикиНоменклатуры, который определяет использование характеристик номенклатуры в прикладном решении;
  • ПолучитьСтавкуНДСЧислом;
  • ЗначениеПеречисленияСтавкаНДС;
  • ПолучитьТекстНастроекОбменаПоСоглашению;
  • ПолучитьТекстЗапросаНастроекОбменаСПриоритетами;

Метод ПолучитьСоответствиеСтавокНДС заменен на метод ЗаполнитьСоответствиеСтавокНДС;

3.Дополнить соответствие в методе ПолучитьСоответствиеСправочников:

СоответствиеСправочников.Вставить("ДоговорыКонтрагентов",        "");


5.

Дополнить соответствие в методе ПолучитьСоответствиеНаименованийОбъектовМДиРеквизитов:

СоответствиеРеквизитовОбъекта.Вставить("ИННКонтрагента",                       "");
СоответствиеРеквизитовОбъекта.Вставить("КППКонтрагента",                       "");
СоответствиеРеквизитовОбъекта.Вставить("НаименованиеКонтрагента",              "");
СоответствиеРеквизитовОбъекта.Вставить("НаименованиеКонтрагентаДляСообщенияПользователю", "");
СоответствиеРеквизитовОбъекта.Вставить("ВнешнийКодКонтрагента",                "");
СоответствиеРеквизитовОбъекта.Вставить("ПартнерКонтрагента",                   "");
СоответствиеРеквизитовОбъекта.Вставить("ИННОрганизации",                       "");
СоответствиеРеквизитовОбъекта.Вставить("КППОрганизации",                       "");
СоответствиеРеквизитовОбъекта.Вставить("НаименованиеОрганизации",              "");
СоответствиеРеквизитовОбъекта.Вставить("СокращенноеНаименованиеОрганизации",   "");

В макетах СчетФактура и КорректировочныйСчетФактура добавлен: блок данных «Комиссионер».

При выставлении счета-фактуры Комитентом Комиссионеру в Организацию помещаются данные Комитента, в Контрагента - данные Покупателя, в Комиссионера - данные Комиссионера. При разборе счета-фактуры на стороне получателя данные Организации помещаются в дерево разбора в блок Контрагент, данные Покупателя - в блок Покупатель, данные коммисионера - в блок Организация.
Устанавливается признак "ВыставленКомитентом“ (принимающий значение Истина если в ЭД присутствуют данные Комиссионера, в противном случае – Ложь);

Во всех макетах ЭД: тип параметра "Ставка НДС" измен