Фирма 1С Система программ Решения Платформа Методическая поддержка Партнерам Другие сайты
Информация
Новости
Пресс-релизы
Публикации в прессе
О фирме 1С
Контакты
Вакансии
Уголок качества
.
 
 
Технологическая платформа
 
Стандартные библиотеки
Система проектирования прикладных решений
Работа в облаке (1cFresh)
Мобильные решения
 
1С:Корпорация
 
1С:Управление холдингом 8
 
1С:ERP Управление предприятием 2
 
1С:Бухгалтерия
 
1С:Учет обращений
 
1С:Упрощенка
 
1С:Предприниматель 2015
 
1С:Управление нашей фирмой
 
1С:Управление
торговлей
 
1С:Управление торговлей.
Базовая версия
 
1С:Зарплата и Управление
Персоналом
 
1С:Комплексная автоматизация 2
 
1С:Управление производственным предприятием
 
1С:Консолидация
 
1С:Платежные документы
 
1С:Налогоплательщик
 
1С:Розница
 
1С:Отчетность предпринимателя
 
1С:Документооборот
 
1С:Договорчики
 
1С:Деньги
 
1С:Бухгалтерия государственного учреждения
 
1C:Зарплата и кадры государственного учреждения
 
1С:Вещевое довольствие
 
1С:Бюджет муниципального образования
 
1С:Бюджет поселения
 
1С:Документооборот государственного учреждения
 
1С:Бюджетная отчетность
 
1С:Свод отчетов
 
1С:Государственные и муниципальные закупки
 
1С:Электронное обучение
 
1С:Управляющий
Локализованные решения
Отраслевые и специализированные решения
Внедренные решения
Самые масштабные проекты
Центры корпоративной технологической поддержки

Интеграция

Как купить и внедрить?
Центры разработки
Партнеры, работающие на корпоративном рынке
Новости и публикации
Обучение
Интернет-поддержка
Версия для печати Поиск Главная

"1С:Библиотека электронных документов 1.3"

Версия 1.3.8

Новые возможности и изменения

Переход на версию 1.3.8 с версии 1.3.7

Версия 1.3.7

Новые возможности и изменения

Переход на версию 1.3.7 с версии 1.3.6

Версия 1.3.6

Новые возможности и изменения

Переход на версию 1.3.6 с версии 1.3.5

Версия 1.3.5

Новые возможности и изменения

Переход на версию 1.3.5 с версии 1.3.4

Версия 1.3.4

Новые возможности и изменения

Переход на версию 1.3.4 с версии 1.3.2, 1.3.3

Версия 1.3.3

Новые возможности и изменения

Переход на версию 1.3.2.19 с версии 1.2.7, 1.3.1

Версия 1.3.2

Новые возможности и изменения

Переход на версию 1.3.2.19 с версии 1.2.7, 1.3.1

Версия 1.3.1

Новые возможности и изменения

Переход на версию 1.3.1 с версии 1.2.6, 1.2.7


Версия 1.3.8

Версия 1.3.8 является развитием редакции 1.3 "1С:Библиотека электронных документов 8", которая предназначена для обеспечения обмена электронными документами в прикладных решениях, разработанных на платформе "1С:Предприятие" версии 8.3.10.2252 и выше.

Значения свойств конфигурации:

  • Режим совместимости должен быть установлен "Не использовать".
  • Режим использования модальности может быть установлен "Не использовать".
  • Режим совместимости интерфейса может принимать значения "Версия 8.2", "Версия 8.2. Разрешить Такси" или "Такси. Разрешить Версия 8.2".

Новые возможности и изменения

  • В форме поиска торговых предложений добавлена возможность поиска без подключения к сервису 1С:Бизнес-сеть, добавлена возможность поиска поставщика по наименованию.
  • Добавлен отчет по публикуемым торговым предложениям.
  • Добавлено рабочее место публикации торговых предложений в сервисе 1С:Бизнес-сеть.
  • Произведена адаптация с подсистемами "1С:Библиотека стандартных подсистем" версия 2.4.2, "1С:Библиотека интернет-поддержки пользователей" версия 2.2.2.

Переход на версию 1.3.8 с версии 1.3.7

Подсистема "Обмен с контрагентами"

Добавлен определяемый тип КонтрагентБЭД, определяемый тип Контрагент удален. При обновлении обязательно установить новый тип данных, в противном случае произойдет удаление данных о контрагентах в объектах подсистемы ОбменСКонтрагентами (документ Пакет электронных документов, регистр сведений Состояния контрагентов БЭД).

Подсистема "Торговые предложения"

Изменения в модуле ТорговыеПредложенияПереопределяемый:

  • Добавлена функция ТекстЗапросаПубликуемыхТоваров для получения источника данных для публикации торговых предложений и формирования отчета о публикуемых товарах. Необходимо реализовать вызов функции методе ЗаполнитьПакетПредложений при получении списка товаров.

Изменения в модуле ТорговыеПредложения

  • Добавлена процедура ОбновитьДекорациюСостоянияПубликации для обновления элемента формы Декорация с состоянием публикации. Необходимо добавить в вызов в форме настройки публикации для элемента состояния.

Добавлена роль ОтчетыТорговыеПредложения необходимая для доступа к отчету ПубликуемыеТорговыеПредложения.


Версия 1.3.7

Версия 1.3.7 является развитием редакции 1.3 "1С:Библиотека электронных документов 8", которая предназначена для обеспечения обмена электронными документами в прикладных решениях, разработанных на платформе "1С:Предприятие" версии 8.3.10 и выше.

Значения свойств конфигурации:

  • Режим совместимости должен быть установлен "Не использовать".
  • Режим использования модальности может быть установлен "Не использовать".
  • Режим совместимости интерфейса может принимать значения "Версия 8.2", "Версия 8.2. Разрешить Такси" или "Такси. Разрешить Версия 8.2".

Новые возможности и изменения

  • Добавлена возможность получения состояния платежного документа из Сбербанка.
  • Реализовано автоматическое получение настроек для Сбербанка при подключении с сервису 1С:ДиректБанк.
  • Добавлена возможность отображения контекстной рекламы 1С:ДиректБанк.
  • Произведена адаптация для работы с сервисом 1С:Бизнес-сеть в облачном сервисе 1CFresh.
  • Добавлена возможность публикации, поиска и заказов торговых предложений в сервисе 1С:Торговые предложения для участников сервиса 1С:Бизнес-сеть.
  • Произведена адаптация с подсистемами "1С:Библиотека стандартных подсистем" версия 2.4.1, "1С:Библиотека интернет-поддержки пользователей" версия 2.1.9, "1С:Библиотека технологии сервиса" версия 1.0.12.

Переход на версию 1.3.7 с версии 1.3.6

Подсистема "Обмен с контрагентами"

Изменения в модуле ОбменСКонтрагентамиПереопределяемый:

  • При формировании электронных документов УПД, УКД, Передача товаров, Передача результатов работ реквизиты ДокументДата, ДокОснованиеДата установлены обязательными к заполнению.

Подсистема "Обмен с банками"

Изменения в модуле РаботаСФайламиПереопределяемый:

  • В процедуру ПриОпределенииНастроек необходимо добавить код:

ЭлектронноеВзаимодействие.ПриОпределенииНастроек(Настройки);

  • В процедуру ПриОпределенииСправочниковХраненияФайлов необходимо добавить код:

ЭлектронноеВзаимодействие.ПриОпределенииСправочниковХраненияФайлов(ТипВладелецФайла, ИменаСправочников);

  • В план обмена ОбновлениеИнформационнойБазы добавлены справочники СообщениеОбменСБанкамиПрисоединенныеФайлы и ЭДПрисоединенныеФайлы
  • В определяемый тип ПодписанныйОбъект добавлены справочники  СообщениеОбменСБанкамиПрисоединенныеФайлы и ЭДПрисоединенныеФайлы.

Отображение контекстной рекламы 1С:ДиректБанк:

В форму выгрузки платежных документов в файл и загрузки банковской выписки из файла (обработка КлиентБанк) перенести группу элементов ГруппаРекламаДиректБанкГоризонтально из общей формы ПредложениеПодключить1СДиректБанк.

В обработчике события формы ПриСозданииНаСервере разместить методы ОбменСБанкамиКлиентСервер.ПоказатьРекламуДиректБанк:

&НаСервере
Процедура ПриСозданииНаСервере (Отказ, СтандартнаяОбработка)
  …
  // ЭлектронноеВзаимодействие.ОбменСБанками
ОбменСБанкамиКлиентСервер.ПоказатьРекламуДиректБанк(
Элементы.ГруппаРекламаДиректБанкГоризонтально, Элементы.ТекстДиректБанкГоризонтально);
  // Конец ЭлектронноеВзаимодействие.ОбменСБанками
КонецПроцедуры

В обработчике события формы ОбработкаОповещения разместить метод ОбменСБанкамиКлиент.ОбновитьРекламуДиректБанк:

& НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
  …
  // ЭлектронноеВзаимодействие.ОбменСБанками
ОбменСБанкамиКлиент.ОбновитьРекламуДиректБанк(ИмяСобытия,
Элементы.ГруппаРекламаДиректБанкГоризонтально, Элементы.ТекстДиректБанкГоризонтально);
  // Конец ЭлектронноеВзаимодействие.ОбменСБанками
КонецПроцедуры
 

Для элемента ТекстДиректБанкГоризонтально добавить обработчик события ОбработкаНавигационнойСсылки и разместить в нем метод ОбменСБанкамиКлиент.ОбработкаНавигационнойСсылкиРекламыДиректБанк:

&НаКлиенте
Процедура ТекстДиректБанкГоризонтальноОбработкаНавигационнойСсылки(Элемент, НавигационнаяСсылкаФорматированнойСтроки, СтандартнаяОбработка)
  ОбменСБанкамиКлиент.ОбработкаНавигационнойСсылкиРекламыДиректБанк(
НавигационнаяСсылкаФорматированнойСтроки, СтандартнаяОбработка);
КонецПроцедуры
 

В процедуру ПолучитьСоответствиеНаименованийОбъектовМДИРеквизитов общего модуля ЭлектронноеВзаимодействие добавить элемент соответствия с ключом ПлатежноеПоручениеВМетаданных и значением: наименование объекта метаданных Платежное поручение в прикладном решении. 

Подсистема "Обмен с сайтами"

Изменения в модуле ОбменССайтомПереопределяемый:

  •  Добавлена процедура ДобавитьРеквизитыФормыУзла, используется для добавления реквизитов в форму узла плана обмена Обмен с сайтом.  В форме узла обмена не предполагается наличие реквизитов, относящихся к прикладному решению, реквизиты добавляются программно.
  • Добавлена процедура ПолеВводаПриИзмененииНаСервере, используется для обработки на севере события ПриИзменнии поля ввода формы узла плана обмена, добавленного в процедуре ДобавитьРеквизитыФормыУзла.
  • Добавлена процедура ПолеФлажкаПриИзмененииНаСервере, используется для обработки на сервере события ПриИзменении поля флажка формы узла плана обмена, добавленного в процедуре  ДобавитьРеквизитыФормыУзла.
  • Добавлена процедура ПриСозданииНаСервереФормаСоздатьСайт, используется для добавления реквизитов в форму обработки СоздатьСайт.

Изменения в модуле ОбменССайтомКлиентПереопределяемый:

  • Удалена процедура ОпределитьТипГруппТаблицыУКаталога, тип значения колонки Группы таблицы КаталогТоваров определяется настройкой обмена.
  • Добавлена процедура ПолеВводаПриИзменении, вызывается для обработки события ПриИзменении поля ввода формы узла плана обмена, добавленного в процедуре  ОбменССайтомПереопределяемый.ДобавитьРеквизитыФормыУзла.
  • Добавлена процедура ПолеФлажкаПриИзменении, вызывается для обработки события ПриИзменении поля флажка формы узла плана обмена, добавленного в процедуре  ОбменССайтомПереопределяемый.ДобавитьРеквизитыФормыУзла.
  • Добавлена процедура ТаблицаФормыПередОкончаниемРедактирования, вызывается для обработки события ПередОкончаниемРедактирования поля табличной части формы узла плана обмена, добавленного в процедуре ОбменССайтомПереопределяемый.ДобавитьРеквизитыФормыУзла.

Подсистема "Бизнес-сеть"

  • Добавлены новые методы для работы регламентных заданий в разделенном режиме, общий модуль ЭлектронноеВзаимодействие, процедуры ПриПолученииСпискаШаблонов, ПриОпределенииПсевдонимовОбработчиков. См. одноименные методы общего модуля ОчередьЗаданийПереопределяемый.
  • При встраивании библиотеки, для работы в разделенном режиме, необходимо добавить вызов методов в общем модуле ОчередьЗаданийПереопределяемый:
    • в процедуре ПриПолученииСпискаШаблонов:

// ЭлектронноеВзаимодействие
ЭлектронноеВзаимодействие.ПриПолученииСпискаШаблонов(ШаблоныЗаданий);
// Конец ЭлектронноеВзаимодействие

  • в процедуре ПриОпределенииПсевдонимовОбработчиков:

// ЭлектронноеВзаимодействие
ЭлектронноеВзаимодействие.ПриОпределенииПсевдонимовОбработчиков(СоответствиеИменПсевдонимам);
// Конец ЭлектронноеВзаимодействие

  • Изменения в модуле БизнесСетьПереопределяемый:
    • переименована процедура ПолучитьКонтактыПользователяИБ в ПолучитьКонтактнуюИнформациюПользователя.
    • процедура СоздатьКонтрагентаПоРеквизитам изменена на функцию СоздатьКонтрагентаПоРеквизитам, удален параметр Контрагент.

Подсистема "Торговые предложения"

Добавлена новая подсистема "Торговые предложения", для встраивания необходимо:

  • Разработать переопределяемые методы в общих модулях ТорговыеПредложенияКлиентПереопределяемый, ТорговыеПредложенияПереопределяемый.
  • Указать типы данных в определяемых типах ВидыЗначенийРеквизитов1СБизнесСеть, ВидыНоменклатурыБЭД, ДополнительныеРеквизитыБЭД, ТорговоеПредложение.

Подробная информация приведена в документации по встраиванию.


Версия 1.3.6

Версия 1.3.6 является развитием редакции 1.3 "1С:Библиотека электронных документов 8", которая предназначена для обеспечения обмена электронными документами в прикладных решениях, разработанных на платформе "1С:Предприятие" версии 8.3.8 и выше. При этом свойство конфигурации "Режим совместимости" должно быть установлено "Версия 8.3.8".

Данная конфигурация предназначена для совместного использования с конфигурацией "1С:Библиотека стандартных подсистем" не ниже версии 2.3.4.112, с конфигурацией "1С:Библиотека интернет-поддержки пользователей 8" не ниже версии 2.1.9.4.

Новые возможности и изменения

  • Поддержаны форматы первичных документов счетов-фактур (в части передачи отдельного первичного документа, счет-фактуры) в соответствии с приказом Федеральной налоговой службы от 24.03.2016 № ММВ-7-15/155@ "Об утверждении формата счета-фактуры и формата представления документа об отгрузке товаров (выполнении работ), передаче имущественных прав (документа об оказании услуг), включающего в себя счет-фактуру, в электронной форме".
  • Поддержаны форматы первичных документов об изменении стоимости, включающего в себя корректировочный счет-фактуру" (в части передачи отдельного первичного документа, корректировочного счет-фактуры) в соответствии с приказом Федеральной налоговой службы от 13.04.2016 N ММВ-7-15/189@ "Об утверждении формата корректировочного счета-фактуры и формат представления документа об изменении стоимости отгруженных товаров (выполненных работ, оказанных услуг), переданных имущественных прав, включающего в себя корректировочный счет-фактуру, в электронной форме".
  • Добавлены новые электронные документы Передача товаров, Передача результатов работ, новая форма визуального представления документов.
  • Добавлен механизм одностороннего обмена, не требующий извещения о получении от получателя.
  • Добавлена возможность управления распаковкой входящих электронных документов (автоматически или вручную), возможность настройки при получении электронных документов создания определенного вида документа.
  • Добавлена возможность привязки электронного документа к нескольким документам учета информационной базы.
  • Реализовано разделение электронных документов на входящие и исходящие.
  • Реализована интеграция с сервисом 1C-UMI позволяющая создавать сайты из программы, настроить обмен с интернет-магазином UMI.
  • Произведена адаптация для работы с сервисом 1С-ЭДО в облачном сервисе 1CFresh.

Переход на версию 1.3.6 с версии 1.3.5

Подсистема "Обмен с контрагентами"

Общий модуль ОбменСКонтрагентамиПереопределяемый

  • Добавлен метод ЗаполнитьДанныеДляУПДИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УПД (информация продавца) функция СЧФДОП.
  • Добавлен метод ЗаполнитьДанныеДляУПДИнформацииПокупателяФНС. Метод подготавливает данные для электронного документа типа УПД (информация покупателя) функция СЧФДОП.
  • Добавлен метод НайтиСоздатьУниверсальныйПередаточныйДокумент. Метод сохраняет данные из электронного документа УПД (информация продавца) функция СЧФДОП в объекты ИБ.
  • Добавлен метод ЗаполнитьДанныеДляДОПИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УПД (информация продавца) функция ДОП.
  • Добавлен метод НайтиСоздатьУПДДокументОПередаче. Метод сохраняет данные из электронного документа УПД (информация продавца) функция ДОП в объект ИБ.
  • Добавлен метод ЗаполнитьДанныеДляСЧФИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УПД (информация продавца) функция СЧФ.
  • Добавлен метод НайтиСоздатьУПДСчетФактуру. Метод сохраняет данные из электронного документа УПД (информация продавца) функция СЧФ в объект ИБ.
  • Добавлен метод ЗаполнитьДанныеДляУКДИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УКД (информация продавца) функция КСЧФДИС.
  • Добавлен метод ЗаполнитьДанныеДляУКДИнформацииПокупателяФНС. Метод подготавливает данные для электронного документа типа УКД (информация покупателя) функция КСЧФДИС.
  • Добавлен метод НайтиСоздатьУниверсальныйКорректировочныйДокумент. Метод сохраняет данные из электронного документа УКД (информация продавца) функция КСЧФДИС в объекты ИБ.
  • Добавлен метод ЗаполнитьДанныеДляДИСИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УКД (информация продавца) функция ДИС.
  • Добавлен метод НайтиСоздатьУКДДокументОбИзмененииСтоимости. Метод сохраняет данные из электронного документа УКД (информация продавца) функция ДИС в объект ИБ.
  • Добавлен метод ЗаполнитьДанныеДляКСЧФИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УКД (информация продавца) функция КСЧФ.
  • Добавлен метод НайтиСоздатьУКДСчетФактуру. Метод сохраняет данные из электронного документа УКД (информация продавца) функция КСЧФ в объект ИБ.
  • Добавлен метод СоответствиеИсходящихВидовЭДДокументамИБ. Метод формирует соответствие исходящих электронных документов и документов ИБ.
  • Добавлен метод НайтиСоздатьДокументПередачаРезультатовРабот. Метод используется заполнения документа Товарная накладная, полученного в формате "Передача товаров".
  • Добавлен метод НайтиСоздатьДокументПередачаТоваров. Метод используется заполнения документа Акт об оказании услуг, полученного в формате "Передача результатов работ".
  • Добавлен метод УстановленоСостояниеОбменЗавершен. Метод вызывается при изменении состояния документооборота на ОбменЗавершен, ОбменЗавершенСИсправлением.
  • При формировании электронных документов УПД, УКД, Передача товаров, Передача результатов работ реквизиты ДокументДата, ДокОснованиеДата установлены обязательными к заполнению.

Обработка ОбменСКонтрагентами

В макете "Торг-12Продавец":

  • Добавлена табличная часть "Основание".
  • Удалены поля "ДокументОснованиеНаименование", "ДокументОснованиеНомер", "ДокументОснованиеДата", "ДокументОснованиеДопСведения".
  • Добавлено поле "ИдГосКонтракта".
  • Добавлена табличная часть "ТранспортнаяНакладная".
  • Удалены поля "ТранспортнаяНакладнаяДата", "ТранспортнаяНакладнаяНомер".
  • Добавлено поле "СведенияОЛицеПередавшемТовары".
  • В свойствах участников сделки поле "Факс" заменено на поле "ЭлектроннаяПочта".
  • В свойствах участников сделки поле "КодСтр" заменено на поле "КодСтраны".
  • В свойствах участников сделки поле "АдрТекст" заменено на поле "АдресТекст".

В макете АктНаПередачуПрав:

  • Добавлена табличная часть "Основание".
  • Удалены поля "ДокументОснованиеНаименование", "ДокументОснованиеНомер", "ДокументОснованиеДата", "ДокументОснованиеДопСведения".
  • Добавлено поле "ВалютаНаименование".
  • Добавлено поле "Претензии".
  • Добавлено поле "ДатаИсполнения".
  • В свойствах участников сделки поле "Факс" заменено на поле "ЭлектроннаяПочта".
  • В свойствах участников сделки поле "КодСтр" заменено на поле "КодСтраны".
  • В свойствах участников сделки поле "АдрТекст" заменено на поле "АдресТекст".

Обновление определяемого типа Контрагент:

При переходе с версии 1.3.5 требуется обновить определяемый тип Контрагент, в противном случае, ссылки на справочник Контрагент в объектах БЭД, при обновлении, заменятся на тип строка с потерей ссылок на объекты без возможности восстановления.

Порядок обновления:

  • Переименовать определяемый тип Контрагент в КонтрагентБЭД.
  • Снять конфигурацию с поддержки БЭД 1.3.5.
  • Запустить сравнение/объединение с конфигурацией БЭД 1.3.5, согласится с установкой конфигурации на поддержку.
  • Снять флажки со всех объектов и оставить только на определяемом типе Контрагент, выполнить объединение.
  • Запустить обновление конфигурации, выбрать файл БЭД 1.3.6.
  • Установить флажки на определяемых типах КонтрагентБЭД и Контрагент. Указать прочие необходимые объекты БЭД для обновления.
  • Выполнить обновление.

Подсистема "Обмен с банками"

В процедуру ПолучитьВыпискуБанка общего модуля ОбменСБанкамиКлиент добавлен необязательный параметр ОткрыватьФормуУточненияПерида с типом Булево. Его необходимо установить Истина, если на форме, с которой осуществляется получение выписки, нет возможности вручную изменить период запроса выписки.

Подсистема "Обмен с сайтами"

Изменен узел обмена ОбменССайтом, форма, модуль объекта:

  • Добавлена возможность выгрузки Номенклатуры с отбором по Видам номенклатуры (ранее была только по группам номенклатуры).

Добавлен справочник Сайты:

  • Добавлена возможность настроить переход на сайт из 1С – в пользовательскую часть сайта, и в админзону сайта.
  • На основании Сайты можно создать узел обмена ОбменССайтом.

Добавлена обработка СоздатьСайт:

  • Добавлена возможность создать сайт в домене 1C-UMI, сайт создается автоматически (элемент Сайты) и заполняется данными из 1С. Автоматически создается узел обмена ОбменССайтом и выполняется первый полный обмен с сайтом.

Общий модуль ОбменССайтомПереопределяемый:

  • Добавлена возможность выбора Видов номенклатуры, удалена возможность выбора произвольного справочника.

Общий модуль ОбменССайтомСобытия:

  • Добавлена возможность выбора Видов номенклатуры.
  • Удалена возможность выбора произвольного справочника.

Прочие изменения

Настройка подсистемы Управление тарифами в модели сервиса библиотеки Технологии сервиса

В общий модуль ТарификацияПереопределяемый в метод ПриФормированииСпискаУслуг() необходимо добавить код после вызова метода ИнтернетПоддержкаПользователей.ПриФормированииСпискаУслуг(ПоставщикиУслуг):

// ЭлектронноеВзаимодействие
ЭлектронноеВзаимодействие.ПриФормированииСпискаУслуг(ПоставщикиУслуг);
// Конец ЭлектронноеВзаимодействие


Версия 1.3.5

Версия 1.3.5 является развитием редакции 1.3 "1С:Библиотеки электронных документов 8", которая предназначена для обеспечения обмена электронными документами в прикладных решениях, разработанных на платформе "1С:Предприятие" версии 8.3.8 и выше.

Значения свойств конфигурации:

  • Режим совместимости должен быть установлен "Не использовать".
  • Режим использования модальности может быть установлен "Не использовать".
  • Режим совместимости интерфейса может принимать значения "Версия 8.2", "Версия 8.2. Разрешить Такси" или "Такси. Разрешить Версия 8.2".

Новые возможности и изменения

  • проведена адаптация функционала библиотеки к особенностям работы на платформе 8.3.8 с отключенным режимом совместимости;
  • обновлены подсистемы "Библиотеки стандартных подсистем" до версии 2.3.3.45;
  • в состав библиотеки включены подсистемы "Библиотеки интернет-поддержки пользователей", версия 2.1.8.3.

Переход на версию 1.3.5 с версии 1.3.4

Изменения не требуются.


Версия 1.3.4

Версия 1.3.4 является развитием редакции 1.3 "1С:Библиотеки электронных документов 8", которая предназначена для обеспечения обмена электронными документами в прикладных решениях, разработанных на платформе "1С:Предприятие" версии 8.3.6 и выше. При этом свойство конфигурации "Режим совместимости" должен быть установлен "Не использовать". Режим использования модальности может быть установлен "Не использовать", а режим совместимости интерфейса может принимать значения "Версия 8.2", "Версия 8.2. Разрешить Такси" или "Такси. Разрешить Версия 8.2".

Новые возможности и изменения

  • реализована система оповещений о событиях ЭДО (новые электронные документы, новые приглашения, окончание срока действия сертификата и т.д.). Появилась возможность настройки уведомлений на электронную почту в профиле настроек ЭДО, а так же вывод оповещения о событиях непосредственно в программе 1С с помощью всплывающих сообщений;
  • поддержан формат первичного документа, включающего в себя счет-фактуру (формат УПД) в соответствии с приказом Федеральной налоговой службы от 24.03.2016 № ММВ-7-15/155@ "Об утверждении формата счета-фактуры и формата представления документа об отгрузке товаров (выполнении работ), передаче имущественных прав (документа об оказании услуг), включающего в себя счет-фактуру, в электронной форме";
  • поддержан формат документа об изменении стоимости, включающего в себя корректировочный счет-фактуру" (формат УКД) в соответствии с приказом Федеральной налоговой службы от 13.04.2016 N ММВ-7-15/189@ "Об утверждении формата корректировочного счета-фактуры и формат представления документа об изменении стоимости отгруженных товаров (выполненных работ, оказанных услуг), переданных имущественных прав, включающего в себя корректировочный счет-фактуру, в электронной форме";
  • поддержано применение внешней компоненты в обмене с банками по технологии DirectBank.

Переход на версию 1.3.4 с версии 1.3.2, 1.3.3 

Изменения в подсистеме "Обмен с контрагентами"

Изменения в формах списков документов прикладного решения

В формах списков документов необходимо добавить подключаемую процедуру Подключаемый_ОбработчикОжиданияЭДО, в которой нужно разместить вызов метода ОбменСКонтрагентамиКлиент.ОбработчикОжиданияЭДО:

&НаКлиенте
Процедура Подключаемый_ОбработчикОжиданияЭДО()
  ОбменСКонтрагентамиКлиент.ОбработчикОжиданияЭДО(ЭтотОбъект);
КонецПроцедуры
 

При обновлении подсистемы необходимо в обработчиках событий формы списка документов: ПриСозданииНаСервере, ПриОткрытии, ОбработкаОповещения

разместить методы подсистемы "ОбменСКонтрагентами".

Пример:

&НаСервере
Процедура ПриСозданииНаСервере
  …
  // Подсистема "ОбменСКонтрагентами".
  ПараметрыПриСозданииНаСервере = ОбменСКонтрагентами.ПараметрыПриСозданииНаСервере_ФормаСписка();
  ПараметрыПриСозданииНаСервере.Форма = ЭтотОбъект;
  ПараметрыПриСозданииНаСервере.МестоРазмещенияКоманд = Элементы.КомандыЭДО;
  ОбменСКонтрагентами.ПриСозданииНаСервере_ФормаСписка(Отказ, СтандартнаяОбработка, ПараметрыПриСозданииНаСервере);
  // Конец подсистема "ОбменСКонтрагентами".
КонецПроцедуры
 
&НаКлиенте
Процедура ПриОткрытии(Отказ)
  …
  // Подсистема "ОбменСКонтрагентами".
  ОбменСКонтрагентамиКлиент.ПриОткрытии(ЭтотОбъект);
  // Конец подсистема "ОбменСКонтрагентами".
КонецПроцедуры
 
&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
  …
  // Подсистема "ОбменСКонтрагентами".
  ПараметрыОповещенияЭДО = ОбменСКонтрагентамиКлиент.ПараметрыОповешенияЭДО_ФормаСписка();
  ПараметрыОповещенияЭДО.Форма = ЭтотОбъект;
  ПараметрыОповещенияЭДО.ИмяДинамическогоСписка = "Список";
  ОбменСКонтрагентамиКлиент.ОбработкаОповещения_ФормаСписка(ИмяСобытия, Параметр, Источник, ПараметрыОповещенияЭДО);
  // Конец подсистема "ОбменСКонтрагентами".
КонецПроцедуры
 

Изменения в формах документов прикладного решения

В формах документов необходимо добавить подключаемую процедуру Подключаемый_ОбработчикОжиданияЭДО, в которой нужно разместить вызов метода

ОбменСКонтрагентамиКлиент.ОбработчикОжиданияЭДО:

&НаКлиенте
Процедура Подключаемый_ОбработчикОжиданияЭДО()
  ОбменСКонтрагентамиКлиент.ОбработчикОжиданияЭДО(ЭтотОбъект);
КонецПроцедуры

В формах документов необходимо удалить реквизит формы "СостояниеЭДО", вместо него добавить элемент формы "декорация". Для нужд прикладного решения декорация может быть подчинена элементу формы "Группа". Видимость группы устанавливается внутри метода ОбменСКонтрагентами.ПриСозданииНаСервере в зависимости от состояния ф.о. "ИспользоватьОбменСКонтрагентами".

При обновлении подсистемы необходимо в обработчиках событий формы документа ПриСозданииНаСервере, ПриОткрытии, ПослеЗаписиНаСервере, ОбработкаОповещения разместить методы подсистемы "ОбменСКонтрагентами".

Например:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
  …
  // Подсистема "ОбменСКонтрагентами".
  ПараметрыЭДОПриСоздании= ОбменСКонтрагентами.ПараметрыПриСозданииНаСервере_ФормаДокумента();
  ПараметрыЭДОПриСоздании.Форма = ЭтотОбъект;
  ПараметрыЭДОПриСоздании.ДокументСсылка = Объект.Ссылка;
  ПараметрыЭДОПриСоздании.ДекорацияСостояниеЭДО = Элементы.ДекорацияСостояниеЭДО;
  ПараметрыЭДОПриСоздании.ГруппаСостояниеЭДО = Элементы.ГруппаСостояниеЭДО;
  ОбменСКонтрагентами.ПриСозданииНаСервере_ФормаДокумента(Отказ, СтандартнаяОбработка, ПараметрыЭДОПриСоздании);
  // Конец подсистема "ОбменСКонтрагентами".
КонецПроцедуры
 
&НаКлиенте
Процедура ПриОткрытии(Отказ)
…  
     // Подсистема "ОбменСКонтрагентами"
     ОбменСКонтрагентамиКлиент.ПриОткрытии(ЭтотОбъект);
     // Конец Подсистема "ОбменСКонтрагентами"
КонецПроцедуры
 
&НаСервере
Процедура ПослеЗаписиНаСервере(ТекущийОбъект, ПараметрыЗаписи)
  …
  // Подсистема "ОбменСКонтрагентами".
  ПараметрыПослеЗаписи = ОбменСКонтрагентами.ПараметрыПослеЗаписиНаСервере();
  ПараметрыПослеЗаписи.Форма = ЭтотОбъект;
  ПараметрыПослеЗаписи.ДокументСсылка = Объект.Ссылка;
  ПараметрыПослеЗаписи.ДекорацияСостояниеЭДО = Элементы.ДекорацияСостояниеЭДО;
  ПараметрыПослеЗаписи.ГруппаСостояниеЭДО = Элементы.ГруппаСостояниеЭДО;
  ОбменСКонтрагентами.ПослеЗаписиНаСервере(ТекущийОбъект, ПараметрыЗаписи, ПараметрыПослеЗаписи);
  // Конец подсистема "ОбменСКонтрагентами". 
КонецПроцедуры
 
&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
  …
  // Подсистема "ОбменСКонтрагентами".
  ПараметрыОповещения = ОбменСКонтрагентамиКлиент.ПараметрыОповешенияЭДО_ФормаДокумента();
  ПараметрыОповещения.Форма = ЭтотОбъект;
  ПараметрыОповещения.ДокументСсылка = Объект.Ссылка;
  ПараметрыОповещения.ДекорацияСостояниеЭДО = Элементы.ДекорацияСостояниеЭДО;
  ПараметрыОповещения.ГруппаСостояниеЭДО = Элементы.ГруппаСостояниеЭДО;
  ОбменСКонтрагентамиКлиент.ОбработкаОповещения_ФормаДокумента(ИмяСобытия, Параметр, Источник, ПараметрыОповещения);
  // Конец подсистема "ОбменСКонтрагентами". 
КонецПроцедуры

Изменения в модуле ОбменСКонтрагентами

  • Добавлена процедура ПриСозданииНаСервере_ФормаСписка, вызывается из обработчика события "ПриСозданииНаСервере" формы списка документов. В качестве третьего параметра метода передается структура, которая инициализируется методом ПараметрыПриСозданииНаСервере_ФормаСписка.
  • Добавлена процедура ПриСозданииНаСервере_ФормаДокумента, вызывается из обработчика события "ПриСозданииНаСервере" формы документа. В качестве третьего параметра метода передается структура, которая инициализируется  методом ПараметрыПриСозданииНаСервере_ФормаДокумента.
  • Добавлена процедура ПослеЗаписиНаСервере, вызывается из обработчика события "ПослеЗаписиНаСервере" формы документа. В качестве третьего параметра метода передается структура, которая инициализируется методом ПараметрыПослеЗаписиНаСервере.

Изменения в модуле ОбменСКонтрагентамиКлиент.

  • Добавлена процедура ПриОткрытии, вызывается из обработчика события "ПриОткрытии" формы списка документов и формы документа.
  • Добавлена процедура ОбработкаОповещения_ФормаСписка, вызывается из обработчика события "ОбработкаОповещения" формы списка документов. В качестве четвертого параметра метода передается структура, которая инициализируется методом ПараметрыОповешенияЭДО_ФормаСписка.
  • Добавлена процедура ОбработкаОповещения_ФормаДокумента, вызывается из обработчика события "ОбработкаОповещения" формы документа. В качестве четвертого параметра метода передается структура, которая инициализируется методом ПараметрыОповешенияЭДО_ФормаДокумента.
  • Изменения в модуле ОбменСКонтрагентамиПереопределяемый:
  • Добавлен метод ЗаполнитьДанныеПередачаРаботИсполнитель.
    Пример:

// Подготавливает данные для электронного документа типа ПередачаТоваровПродавец.
//
// Параметры:
//  СсылкаНаОбъект   - Ссылка на ЭД, по которому необходимо сформировать электронный документ,
//  СтруктураЭД - Структура, структура данных для формирования электронного документа.
//  ДеревоДанных - дерево значений, дерево данных заполнения электронного документа.
//
Процедура ЗаполнитьДанныеПередачаРаботИсполнитель(СсылкаНаОбъект, СтруктураЭД, ДеревоДанных) Экспорт
  ЗаполнитьДанныеПоАкт501ИсполнительФНС(СсылкаНаОбъект, СтруктураЭД, ДеревоДанных)
КонецПроцедуры
 

  • Метод ПроверитьВозможностьРедактированияОбъекта стал процедурой.
  • Добавлен метод ЗаполнитьДанныеДляУПДИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УПД (информация продавца) функция СЧФДОП.
  • Добавлен метод НайтиСоздатьУниверсальныйПередаточныйДокумент. Метод сохраняет данные из электронного документа УПД (информация продавца) функция СЧФДОПв объекты ИБ.
  • Добавлен метод ЗаполнитьДанныеДляУКДИнформацияПродавцаФНС. Метод подготавливает данные для электронного документа типа УКД (информация продавца) функция КСЧФДИС.
  • Добавлен метод НайтиСоздатьУниверсальныйКорректировочныйДокумент. Метод сохраняет данные из электронного документа УКД (информация продавца) функция КСЧФДИС в объекты ИБ.

Изменения в подсистеме "Обмен с банками"

Изменения в модуле ОбменСБанкамиПереопределяемый

Процедура ПриИзмененииСостоянияЭД добавлена. Вызывается при изменении состояния электронного документооборота.

Изменения для работы в режиме сервиса

Если конфигурация предназначения для работы в режиме сервиса необходимо:

  • В процедуру ПолучитьОбработчикиПоставляемыхДанных общего модуля ПоставляемыеДанныеПереопределяемый добавить код:

ЭлектронноеВзаимодействие.ЗарегистрироватьОбработчикиПоставляемыхДанных(Обработчики);

  • В общий реквизит ОбластьДанныхОсновныеДанные добавить регламентное задание ОбновлениеВнешнихМодулейОбменСБанками.

Прочие изменения

  • В определяемый тип МестоХраненияФункциональныхОпций необходимо добавить константу ИспользоватьОбменСБанками;
  • Удалена функция ОбменСБанками.РекомендуетсяПрямойОбменСБанком.


Версия 1.3.3

Версия 1.3.3 является развитием редакции 1.3 продукта "1С:Библиотека электронных документов". Предназначена для разработки конфигураций, которые рассчитаны для работы на платформе 1С:Предприятие 8.3 версии 8.3.6 и выше.

Значения свойств конфигурации:

  • Режим совместимости должен быть установлен "Не использовать".
  • Режим использования модальности может быть установлен "Не использовать".
  • Режим совместимости интерфейса может принимать значения "Версия 8.2", "Версия 8.2. Разрешить Такси" или "Такси. Разрешить Версия 8.2".

Новые возможности и изменения

  • в соответствии с Приказом от 30.11.2015 № ММВ-7-10/551@ "Об утверждении формата представления документа о передаче товаров при торговых операциях в электронной форме" и Приказом от 30.11.2015 № ММВ-7-10/552@ "Об утверждении формата представления документа о передаче результатов работ (документа об оказании услуг) в электронной форме" поддержаны новые форматы электронных документов.

Переход на версию 1.3.2.19 с версии 1.2.7, 1.3.1 

Изменения в подсистеме "Обмен с контрагентами"

В модуле ОбменСКонтрагентамиПереопределяемый внести изменение:

// Подготавливает данные для электронного документа типа ТоварнаяНакладная.
//
// Параметры:
//  СсылкаНаЭД   - Ссылка на ЭД, по которому необходимо сформировать электронный документ,
//  СтруктураЭД - Структура, структура данных для формирования электронного документа.
//  ДеревоДанных - дерево значений, дерево данных заполнения электронного документа.
//
Процедура ЗаполнитьДанныеПередачаТоваровПродавец(СсылкаНаОбъект, СтруктураЭД, ДеревоДанных) Экспорт
  ЗаполнитьДанныеПоТорг12ПродавецФНС(СсылкаНаОбъект, СтруктураЭД, ДеревоДанных)
КонецПроцедуры

Необходимо добавить в конфигурацию, использующую БЭД, шаблоны по ограничению доступа на уровне записи по организациям (RLS) при работе с электронными документами (см. документацию по встраиванию).


Версия 1.3.2

Версия 1.3.2 является развитием редакции 1.3 продукта "1С:Библиотека электронных документов". Предназначена для разработки конфигураций, которые рассчитаны для работы на платформе 1С:Предприятие 8.3 версии 8.3.6 и выше.

Значения свойств конфигурации:

  • Режим совместимости должен быть установлен "Не использовать".
  • Режим использования модальности может быть установлен "Не использовать".
  • Режим совместимости интерфейса может принимать значения "Версия 8.2", "Версия 8.2. Разрешить Такси" или "Такси. Разрешить Версия 8.2".

Новые возможности и изменения

  • реализовано отображение 2-х титулов электронных документов (ТОРГ12, Акт, Корректировочные документы) в единой форме просмотра электронного документа. Вся информация из титулов будет собрана на единую форму. Отдельно форму второго титула можно будет посмотреть из формы "Электронный документы";
  • реализована возможность заключать типовое "Соглашение об ЭДО" в электронном виде из "Настройки ЭДО" в программе 1С; По команде "Сформировать соглашение по шаблону" автоматически будет создан произвольный электронный документ, вложением которого будет файл соглашения. После подписания документ можно будет сразу отправить контрагенту.
  • интегрирован обмен произвольными электронными документами с присоединенными файлами. Теперь любой присоединенный файл можно быстро подписать и отправить контрагенту с помощью произвольного электронного документа;
  • поддержана возможность обмениваться эл.документами с банком по зарпл.проекту;
  • добавлен помощник подключения организации к DirectBank;
  • реализовано обновление списка банков, поддержавших DirectBank, через Интернет;
  • поддержана работа с разными видами токенов (эл.ключами) Сбербанка: "обычный", "сенсорный", "с экраном".
  • обновлены подсистемы "Библиотеки стандартных подсистем" (БСП) до версии 2.3.2.27.

Переход на версию 1.3.2.19 с версии 1.2.7, 1.3.1

Изменения в подсистеме "Обмен с банками"

Необходимо выполнить добавление процедуры без заполнения в модуль ОбменСБанкамиПереопределяемый:

процедура ПроверитьИспользованиеТестовогоРежима. Включает возможность включения дополнительных возможностей для тестирования обмена с банками. Использовать в прикладных решениях пока не планируется;

В модуле РегламентныеЗаданияПереопределяемый внести изменение:

Процедура ПриОпределенииНастроекРегламентныхЗаданий(Настройки) Экспорт
  ЭлектронноеВзаимодействие.ПриОпределенииНастроекРегламентныхЗаданий(Настройки);
КонецПроцедуры

В модуле ЭлектроннаяПодписьКлиентПереопределяемый внести изменение:

Процедура ПриДополнительнойПроверкеСертификата(Параметры) Экспорт
  ОбменСБанкамиКлиент.ПриДополнительнойПроверкеСертификата(Параметры);
КонецПроцедуры

В модуль ЭлектроннаяПодписьПереопределяемый внести изменение:

Процедура ПриСозданииФормыПроверкаСертификата(Сертификат, ДополнительныеПроверки, ПараметрыДополнительныхПроверок, СтандартныеПроверки) Экспорт
  ОбменСБанками.ПриСозданииФормыПроверкаСертификата(
        Сертификат, ДополнительныеПроверки, ПараметрыДополнительныхПроверок, СтандартныеПроверки);
КонецПроцедуры

Добавлены следующие неразделенные объекты:

  • Регламентное задание ЗагрузкаСпискаDirectBank;
  • Константа ОбщиеФайлыОбменСБанками.

В определяемый тип МестоХраненияФункциональныхОпций добавить константу ИспользоватьОбменСБанками.

Если конфигурация предназначена для работы в режиме модели сервиса, то необходимо Обработчик подписки на событие КонтрольНеразделенныхОбъектовПриЗаписиБЭД изменить на РаботаВМоделиСервиса.КонтрольНеразделенныхОбъектовПриЗаписи.

Версия 1.3.1

Версия 1.3.1 является развитием редакции 1.2 продукта "1С:Библиотека электронных документов". Предназначена для разработки конфигураций, которые рассчитаны для работы на платформе 1С:Предприятие 8.3 версии 8.3.6 и выше.

Значения свойств конфигурации:

  • Режим совместимости должен быть установлен "Не использовать".
  • Режим использования модальности может быть установлен в "Не использовать".
  • Режим совместимости интерфейса может принимать значения "Версия 8.2", "Версия 8.2. Разрешить Такси" или "Такси. Разрешить Версия 8.2".

Новые возможности и изменения

  • реализована возможность обмена электронными документами без электронной подписи через сервис ЭДО для участников 1С:Бизнес-сеть;
  • реализована автономная подсистема обмена с банками;
  • обновлены подсистемы "Библиотеки стандартных подсистем" (БСП) до версии 2.3.1.71.

Переход на версию 1.3.1 с версии 1.2.6, 1.2.7

Изменения архитектуры

Все модули с префиксом "ЭлектронныеДокументы" переименованы в модули с префиксом "ОбменСКонтрагентами". Методы модуля ОбщегоНазначенияЭД перенесены в новый модуль ЭлектронноеВзаимодействие. Модуль ОбновлениеИнформационнойБазыЭД переименован в ОбновлениеИнформационнойБазыБЭД.

Список методов, которые были перенесены из модуля ЭлектронныеДокументы в ЭлектронныеВзаимодействие:

  • ФамилияИнициалыФизЛица

Список методов, которые были перенесены из модуля ЭлектронныеДокументы в ОбменСБанками:

  • ВозможенПрямойОбменСБанком
  • ПолучитьДанныеВыпискиБанкаДеревоЗначений
  • ПолучитьДанныеВыпискиБанкаТекстовыйФормат
  • ДеревоРазбораВыпискиБанка

Список методов, которые были перенесены из модуля ЭлектронныеДокументыКлиентПереопределяемый в ЭлектронныеВзаимодействиеКлиентПереопределяемый:

  • ПодготовитьТекстСообщенияОНарушенииПравДоступа
  • ВыполнитьПроверкуПроведенияДокументов

Список методов, которые были перенесены из модуля ЭлектронныеДокументыКлиентПереопределяемый в ОбменСБанкамиКлиентПереопределяемый:

  • РазобратьФайлВыписки

Список методов, которые были перенесены из модуля ЭлектронныеДокументыКлиентСервер в ЭлектронныеВзаимодействиеКлиентСервер:

  • ПолучитьТекстСообщения (переименован в ТекстСообщения)
  • ЕстьДействие

Список методов, которые были перенесены из модуля ЭлектронныеДокументыКлиентСервер в ОбменСБанкамиКлиентСервер:

  • ЗаполненыРеквизитыНастройкиЭДОСБанками (переименован в ЗаполненыРеквизитыНастройкиОбмена)
  • ЗаголовокНастройкиЭДОСБанком переименован в ЗаголовокНастройкиОбменаСБанком
  • ПолучитьТекстСостоянияЭД

Список методов, которые были перенесены из модуля ЭлектронныеДокументыПереопределяемый в ЭлектронныеВзаимодействиеПереопределяемый:

  • ИзменитьСвойстваЭлементовФормы
  • ТекущийКаталогВременныхФайлов
  • ПолучитьСоответствиеФункциональныхОпций
  • ПолучитьСоответствиеСправочников
  • ПолучитьСоответствиеНаименованийОбъектовМДиРеквизитов
  • СоответствиеКодовРеквизитовИПредставлений
  • ПолучитьСтруктуруКлючевыхРеквизитовОбъекта
  • ТекстСообщенияОНеобходимостиНастройкиСистемы
  • ИзменитьСообщениеОбОшибке
  • ПодготовитьТекстСообщенияОНарушенииПравДоступа
  • РазобратьНаименованиеФизЛица
  • НайтиСсылкуНаОбъект
  • ПолучитьПечатныйНомерДокумента
  • ПроверитьГотовностьИсточников
  • ПолучитьДанныеЮрФизЛица
  • ОписаниеОрганизации
  • ЕстьПравоОбработкиЭД
  • ЕстьПравоЧтенияЭД
  • ЕстьПравоОткрытияЖурналаРегистрации

Список методов, которые были перенесены из модуля ЭлектронныеДокументыПереопределяемый в ОбменСБанкамиПереопределяемый:

  • ПолучитьАктуальныеВидыЭД
  • ПолучитьНомераБанковскихСчетов
  • ЗаполнитьПараметрыЭДПоИсточнику
  • ЗаполнитьДанныеПоПлатежномуПоручению
  • ЗаполнитьДанныеПоПлатежномуТребованию
  • ПроверитьВозможностьРедактированияОбъекта

Из подписок на события НазначитьНовуюВерсиюЭДПриЗаписиВладельца и ПроверитьИзменениеПередЗаписьюВладельцаЭД удалены банковские документы.

Перенесены макеты из обработки ОбменСКонтрагентами в ОбменСБанками:

  • ПлатежноеПоручение
  • ПлатежноеТребование

В определяемый тип ВладелецПрисоединенныхФайловОбъект необходимо добавить

  • документОбъект.ПакетЭД
     

Изменения интерфейсов

  • В общих модулях ОбменСБанками, ОбменСКонтрагентами добавлены процедуры ПриСозданииНаСервере. Вызываются при открытии форм объектов для формирования команд ЭДО. Параметры: Форма – текущая форма, МестоРазмещенияКомандПоУмолчанию – элемент формы подменю, в котором будут созданы команды ЭДО.
  • В общих модулях ОбменСБанкамиПереопределяемый, ОбменСКонтрагентамиПереопределяемый добавлены процедуры для формирования списка команд ЭДО ПодготовитьСтруктуруОбъектовКомандЭДО. Параметр СоставКомандЭДО может быть массивом (для подсистемы ОбменСБанками) или структурой массивов (ОбменСКонтрагентами).
  • Удалена группа команд ЭДО, автоматическое заполнение командной панели командами ЭДО более не производится.

Для создания команд ЭДО в формах документов информационной базы необходимо добавить код для формирования видов объектов в процедуре переопределяемого общего модуля.

Пример в модуле ОбменСКонтрагентамиПереопределяемый:

Процедура ПодготовитьСтруктуруОбъектовКомандЭДО(СоставКомандЭДО) Экспорт
  СоставКомандЭДО.Исходящие.Добавить("Документ.РеализацияТоваровУслуг");
  СоставКомандЭДО.Исходящие.Добавить("Документ.ЗаказПокупателя");
  …
  СоставКомандЭДО.Входящие.Добавить("Документ.ПоступлениеТоваровУслуг");
  СоставКомандЭДО.Входящие.Добавить("Документ.СчетФактураПолученный");
  …
КонецПроцедуры

ОбменСБанкамиПереопределяемый:

Процедура ПодготовитьСтруктуруОбъектовКомандЭДО(СоставКомандЭДО) Экспорт
  СоставКомандЭДО.Добавить("Документ.ПлатежноеПоручение");
  СоставКомандЭДО.Добавить("Документ.ПлатежноеТребование");
  …
КонецПроцедуры

При создании формы производить вызов программного формирования команд

ОбменСКонтрагентами.ПриСозданииНаСервере:

Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
  // КомандыЭДО
  ОбменСКонтрагентами.ПриСозданииНаСервере(ЭтотОбъект, Элементы.КомандыЭДО);
  // Конец КомандыЭДО
КонецПроцедуры

Добавить подключаемый обработчик формы Подключаемый_ВыполнитьКомандуЭДО:

Процедура Подключаемый_ВыполнитьКомандуЭДО(Команда)
  ЭлектронноеВзаимодействиеСлужебныйКлиент.ВыполнитьПодключаемуюКомандуЭДО(Команда, ЭтаФорма, Элементы.Список);
КонецПроцедуры

Изменения в подсистеме "Обмен с контрагентами"

  • заполнить определяемый тип "ОснованияПроизвольногоЭД" типами документов, на основании которых будут вводиться Произвольные ЭД (скорее всего это будут те же документы, что и в определяемом типе ВладелецПрисоединенныхФайлов), так же в этих документах надо добавить документ "ПроизвольныйЭД" в список "Является основанием для:"
  • в формах документов и списках документов (на основании которых вводится Произвольный ЭД) надо отключить в подменю "Создать на основании" Произвольный ЭД, т.к. команда ввода Произвольного ЭД вынесена в подменю ЭДО (команда "Добавить файл");
  • в макетах АктНаПередачуПрав, ЗаказТовара, ОтветНаЗаказ, ОтчетКомиссионераОПродажах, ОтчетКомиссионераОСписании, СчетНаОплату, КаталогТоваров, ПрайсЛист в группе параметров "Банк" у поле "БИК" изменен признак обязательного заполнения. Необходимо предусмотреть заполнение данного поля;
  • в макете СчетФактура изменился формат полей КодСтраныПроисхождения и НомерТаможеннойДекларации. Для более корректного заполнения, они объеденены в таблицу ТаможеннаяДекларация. Пример заполнения этих элементов в процедуре подготовки данных ЭСФ, можно посмотреть в демо базе БЭД.

Изменения в модуле ОбменСКонтрагентамиКлиент

  • Устарел метод ОткрытьСписокЭД. Вместо него рекомендуется использовать ОткрытьДеревоЭД, который открывает пользователю на дерево регламента обмена электронными документами по документу ИБ.

Изменения в модуле ЭлектронноеВзаимодействиеПереопределяемый

В метод ПолучитьСоответствиеНаименованийОбъектовМДиРеквизитов добавлены для переопределения два ключа:

  • РеализацияТоваровУслугВМетаданных
  • ПоступлениеТоваровУслугВМетаданных

Изменения в модуле ОбменСКонтрагентами

Добавлен метод ЗаполнитьДанныеПо1СЭДОДляМастера1СОтчетности, который готовит данные для мастера 1С-Отчетности.

Добавлен метод ПроверитьКонтрагентаВ1СЭДОПриСозданииНаСервере, который необходимо вызвать при создании формы контрагента. Данный метод запускает проверку на подключение контрагента к сервису 1С-ЭДО.
Пример ОбменСКонтрагентами.ПроверитьКонтрагентаВ1СЭДОПриСозданииНаСервере:

Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
 // ЭлектронноеВзаимодействие.ОбменСКонтрагентами
 ОбменСКонтрагентами.ПроверитьКонтрагентаВ1СЭДОПриСозданииНаСервере(Объект.Ссылка);
 // Конец ЭлектронноеВзаимодействие.ОбменСКонтрагентами
КонецПроцедуры

Добавлено НЕ разделенное регламентное задание ПроверкаКонтрагентовБЭД, которое делает выборку контрагентов и выполняет по ним проверку подключения к 1С-ЭДО.

Добавлен разделенный регистр сведений СостоянияКонтрагентовБЭД, в котором собирается статистика по подключенным контрагентам к сервису 1С-ЭДО.

Добавить вывод признака подключения к сервису 1С-ЭДО в колонку "ЭДО" на форме списка и форме выбора контрагентов. Добавить подсказку к колонке "Подключен к сервису 1С-ЭДО".
Пример:

ВЫБРАТЬ
 ВЫБОР
  КОГДА СостоянияКонтрагентовБЭД.Состояние = ЗНАЧЕНИЕ(Перечисление.СостоянияКонтрагентаБЭД.Подключен)
   ТОГДА 0
  ИНАЧЕ 1
   КОНЕЦ
 КОНЕЦ КАК ЭДО,
 СправочникКонтрагенты.Наименование,
 СправочникКонтрагенты.ИНН,
 СправочникКонтрагенты.КПП,
....
 СправочникКонтрагенты.НаименованиеПолное
ИЗ
 Справочник.Контрагенты КАК СправочникКонтрагенты
  ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.СостоянияКонтрагентовБЭД КАК СостоянияКонтрагентовБЭД
  ПО (СостоянияКонтрагентовБЭД.Контрагент = СправочникКонтрагенты.Ссылка)

 
На формах документов информационной базы необходимо убрать привязку к функциональной опции "ИспользоватьОбменЭД" у реквизита формы "ТекстСостоянияЭД". Удалить заголовок у реквизита "Состояние ЭД".

Изменения в подсистеме "Обмен с банками"

Добавлены подписки на события ОбменСБанкамиВладелецЭДПередЗаписью и ОбменСБанкамиВладелецЭДПриЗаписи.

  • Добавлены определяемые типы ВладельцыОбменСБанками и СправочникБанки.
  • Добавлена общая команда НастройкиОбменСБанками.

В определяемый тип ПрисоединенныйФайл добавить:

  • справочникСсылка.СообщениеОбменСБанкамиПрисоединенныеФайлы;
  • справочникОбъект.СообщениеОбменСБанкамиПрисоединенныеФайлы;
  • справочникСсылка.ПакетОбменСБанкамиПрисоединенныеФайлы;
  • справочникОбъект.ПакетОбменСБанкамиПрисоединенныеФайлы.

В определяемый тип ВладелецПрисоединенныхФайлов необходимо добавить

  • документСсылка.СообщениеОбменСБанками;
  • документСсылка.ПакетОбменСБанками.

В определяемый тип ВладелецПрисоединенныхФайловОбъект необходимо добавить

  • документОбъект.СообщениеОбменСБанками;
  • документОбъект.ПакетОбменСБанками;
  • документОбъект.ПакетЭД

Добавлена новая подсистема "БизнесСеть"

В состав подсистемы входят общие модули (префикс ОбменБизнесСеть), обработка БизнесСеть, роли (АдминистрированиеАбонентаБизнесСеть, ВыполнениеОбменаБизнесСеть), регистр сведений ИдентификаторыБизнесСеть. В форме "Настройка обмена электронными документами" добавлена команда вызова формы подключения к сервису.

Необходимо выполнить заполнение процедур и функций в модуле БизнесСетьПереопределяемый:

  • метод СоздатьКонтрагентаПоРеквизитам. Создает контрагента в прикладном решении по переданным параметрам;
  • метод ПолучитьКонтактыПользователяИБ. Получает контактную информацию пользователя (наименование роли, электронный адрес);
  • метод ВыполнитьКонтрольРеквизитовДокументов. Проверяет реквизиты документов для возможности отправки массива (отправитель и получатель должны быть одинаковыми).


Переход на версию 1.3.7 с версии 1.3.6

Отображение контекстной рекламы 1С:ДиректБанк:

В форму выгрузки платежных документов в файл и загрузки банковской выписки из файла (обработка КлиентБанк) перенести группу элементов ГруппаРекламаДиректБанкГоризонтально из общей формы ПредложениеПодключить1СДиректБанк.

В обработчике события формы ПриСозданииНаСервере разместить методы ОбменСБанкамиКлиентСервер.ПоказатьРекламуДиректБанк:

&НаСервере
Процедура ПриСозданииНаСервере (Отказ, СтандартнаяОбработка)
  …
  // ЭлектронноеВзаимодействие.ОбменСБанками
ОбменСБанкамиКлиентСервер.ПоказатьРекламуДиректБанк(
Элементы.ГруппаРекламаДиректБанкГоризонтально, Элементы.ТекстДиректБанкГоризонтально);
  // Конец ЭлектронноеВзаимодействие.ОбменСБанками
КонецПроцедуры

В обработчике события формы ОбработкаОповещения разместить метод ОбменСБанкамиКлиент.ОбновитьРекламуДиректБанк:

& НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
  …
  // ЭлектронноеВзаимодействие.ОбменСБанками
ОбменСБанкамиКлиент.ОбновитьРекламуДиректБанк(ИмяСобытия,
Элементы.ГруппаРекламаДиректБанкГоризонтально, Элементы.ТекстДиректБанкГоризонтально);
  // Конец ЭлектронноеВзаимодействие.ОбменСБанками
КонецПроцедуры

Для элемента ТекстДиректБанкГоризонтально добавить обработчик события ОбработкаНавигационнойСсылки и разместить в нем метод ОбменСБанкамиКлиент.ОбработкаНавигационнойСсылкиРекламыДиректБанк:

&НаКлиенте
Процедура ТекстДиректБанкГоризонтальноОбработкаНавигационнойСсылки(Элемент, НавигационнаяСсылкаФорматированнойСтроки, СтандартнаяОбработка)
  ОбменСБанкамиКлиент.ОбработкаНавигационнойСсылкиРекламыДиректБанк(
НавигационнаяСсылкаФорматированнойСтроки, СтандартнаяОбработка);
КонецПроцедуры

В процедуру ПолучитьСоответствиеНаименованийОбъектовМДИРеквизитов общего модуля ЭлектронноеВзаимодействие добавить элемент соответствия с ключом ПлатежноеПоручениеВМетаданных и значением: наименование объекта метаданных Платежное поручение в прикладном решении.

09.06.2017
   © ООО «1С»

Отправить ваши замечания и предложения по сайту