Версия для печати Поиск
Главная Методическая поддержка Книги, буклеты, статьи

«1С:Предприятие 8. Простые примеры разработки»

Исправления и комментарии

Как и любое другое издание, книга «1С:Предприятие 8. Простые примеры разработки», к сожалению, не избавлена от небольших неточностей. Ниже приводится их список.

Если вы обнаружили неточность, не внесенную в этот список, сообщите нам об этом по электронной почте v8@1c.ru.

Страница 29

Как реализовать код процедуры в зависимости от режима выполнения (на клиенте, на сервере, во внешнем соединении)?

В коде примера допущена неточность.

Вместо:

#Если ВнешнееСоединение Тогда
  // Фрагмент кода, который должен выполняться в сессии внешнего соединения. 
#КонецЕсли 
					 
#Если Клиент Тогда 
   // Фрагмент кода, который должен выполняться на сервере.
#КонецЕсли 
		  
#Если Сервер Тогда 
   // Фрагмент кода, который должен выполняться на клиентском месте.
#КонецЕсли

Следует читать:

#Если ВнешнееСоединение Тогда 
   // Фрагмент кода, который должен выполняться в сессии внешнего соединения. 
#КонецЕсли 
					 
#Если Клиент Тогда 
   // Фрагмент кода, который должен выполняться на клиентском месте. 
#КонецЕсли 
					  
#Если Сервер Тогда 
 // Фрагмент кода, который должен выполняться на сервере. 
#КонецЕсли

В приложении на копакт-диске этот пример приведен правильно.